Un comportamento anomalo

Mele e appunti

Circa due mesi fa notai un’anomalia nel comportamento del mio nuovo MacBook Pro nel collegamento a caldo con il monitor LCD esterno che utilizzo quando lavoro in postazione ‘desktop’, e scrissi il seguente messaggio in alcune mailing list a cui sono iscritto:

Sto cercando informazioni su Internet riguardo al problema che sto per descrivere, ma non ho trovato niente di preciso o definitivo. Vediamo se qui qualcuno ha un’idea.

Hardware in questione

  • MacBook Pro 15″ unibody (mid 2009), 2,66 GHz Core 2 Duo, 4 GB RAM. Mac OS X 10.5.8.
  • Monitor Belinea o.display 20″ LCD widescreen con uscita VGA. Risoluzione 1680x1050.
  • Adattatore VGA /–/ mini DisplayPort.

Il problema
Uso abitualmente il MacBook Pro in configurazione desktop, collegato al monitor suddetto mediante l’adattatore in questione, e ovviamente in modalità scrivania estesa.

Se scollego a caldo l’adattatore, il MacBook Pro rileva il cambio e passa al suo monitor, raccogliendo e ridimensionando le finestre, eccetera. Come dovrebbe fare. Quindi tutto OK.

Quando, magari rientrato a casa dopo aver usato il MacBook Pro on the road, lo ricollego al monitor (che nel frattempo è in stop) a caldo, il MacBook Pro si spegne. Così, all’improvviso, come se di punto in bianco mancasse ogni forma di alimentazione. Pigiando il pulsante di accensione, il Mac si avvia e fa tutto normalmente, rilevando il monitor e sistemando la scrivania di conseguenza.

I tentativi di risoluzione del problema
Ho provato a vedere se era un problema legato alla scheda NVIDIA 9400, ma anche passando alla 9600 prima di collegare il monitor, il MacBook Pro si comporta così.

Ho provato a collegarlo spegnendo prima il monitor, ma non cambia niente. L’unica è spegnere il MacBook Pro, collegarlo al monitor, e poi accendere. Che non è proprio il massimo della praticità, ne converrete. Questo non mi è mai successo con il PowerBook G4 12″ e l’adattatore DVI /–/ VGA, al quale ho sempre collegato/scollegato quel monitor, a caldo, senza problemi.

Può essere colpa dell’adattatore? Ogni idea è ben accetta. E grazie in anticipo.

In un messaggio seguente, aggiunsi:

Nel frattempo ho notato che collegando l’adattatore mentre il MacBook Pro è in stop non succede nulla di critico, e ciò è buono. L’unico inconveniente è che quando lo risveglio lui rileva il monitor, ma perde completamente ogni impostazione assegnata in precedenza: mi duplica la scrivania invece di estenderla, e passa a una risoluzione inferiore sia sul monitor esterno che su quello interno. Mi tocca reimpostare, ma se non altro è meglio che dover spegnere il MacBook Pro ogni volta che devo ricollegarlo al monitor.

Io continuo a pensare sia un problema legato all’adattatore. Ma al tempo stesso non vedo l’ora che mi arrivi Snow Leopard per verificare se il comportamento cambia o meno con il nuovo gattone.

Avendo preso l’abitudine di collegare/scollegare il monitor esterno mentre il MacBook Pro dorme, e avendo molte altre cose per la testa in questo periodo, mi stavo dimenticando del problema in oggetto. Me ne sono ricordato ieri perché ho inavvertitamente connesso il monitor con il MacBook Pro acceso e puf! — spegnimento istantaneo del Mac. Un particolare a cui non ho dato sufficientemente peso nel primo messaggio è che questi spegnimenti istantanei del MacBook Pro non sono affatto benefici se, per esempio, si tengono svariate applicazioni aperte con documenti non salvati e lavori in corso. Grazie al cielo programmi come MarsEdit (che utilizzo per scrivere e pubblicare i miei articoli in tutti i blog che gestisco) hanno funzioni di autosalvataggio e ricupero a seguito di crash improvvisi, ma non sempre si ha questa fortuna. I client di posta sono più suscettibili, e ho già dovuto ricostruire caselle in Mail e Mailsmith; in un caso isolato ho anche perduto dei messaggi, fortunatamente non di primaria importanza.

Il problema rimane. Gli unici cambiamenti rispetto a due mesi fa è che ora ho installato Mac OS X 10.6.1 al posto del 10.5.8, e che finalmente le impostazioni del monitor rimangono memorizzate, quindi non devo reimpostare risoluzioni, disposizioni di scrivanie, profili di calibrazione e annessi e connessi. Ho provato a farmi cambiare l’adattatore ma, avendolo acquistato a giugno, alla FNAC mi hanno risposto picche. L’unico suggerimento utile che mi è pervenuto dalle mailing list a cui ho chiesto aiuto è stato quello di resettare il power manager del MacBook Pro, ma la cosa non ha sortito effetto alcuno. Il Mac, sottolineo, funziona egregiamente in tutto e per tutto, e non manifesta stranezze né a livello di batteria, né di alimentatore, né di contatti: le ricariche avvengono regolarmente, nei tempi consueti, senza anomalie di sorta. Per ora non posso spendere 30 Euro in un secondo adattatore video, per poi magari scoprire che il problema permane, ma non so davvero da che cosa possa dipendere questa anomalia.

The Author

Writer. Translator. Mac consultant. Enthusiast photographer. • If you like what I write, please consider supporting my writing by purchasing my short stories, Minigrooves or by making a donation. Thank you!

7 Comments

  1. Insieme al MacBook Pro ho preso l’adattatore DVI pensando di poterlo in accoppiata all’adattatore DVI-VGA che era insieme al vecchio MacBook Pro. La cosa però non è fattibile dato che l’adattatore Mini DisplayPort è solo DVI-D e non DVI-I e quindi non ha i pin per la VGA.
    Ovviamente non ho monitor DVI in casa :D
    Appena me ne capita uno sotto mano vedrò di fare una prova.

  2. Marco says

    Riccardo, la mia situazione è diversa e più aleatoria, ma in parte legata alla tua.
    Ho anche io un MBP 15. Il mio monitor è invece un Samsung T240HD che collego tramite un adattatore MiniDP — DVI

    Anche io ho avuto qualche problema con la connessione a caldo del monitor, ma — guarda un po’ — viceversa quando operavo con il MBP in stop (con lo schermo chiuso per intenderci).
    In pratica non veniva fuori dallo STOP, il MBP sembrava morto, non mi restava che forzare lo spegnimento completo (tenendo premuto il pulsante del power) e ripartire.
    Il fenomeno però non si presentava in modo sistematico e non sono mai riuscito a capire bene come e quando capitasse.

    Come te mi capitava di rientrare da una situazione “on the road” con il computer in borsa e ovviamente in stop e niente di più comodo sarebbe stato metterlo in posizione e collegare i 3 cavi (alimentazione, usb e miniDP). E invece ho preso l’abitudine di aprire lo schermo e far ripartire il MBP dallo stop prima di collegare il monitor.

    Parlo al passato perchè è da un po’ che non mi ricapita. Adesso ho SL, ma c’è anche da dire che sempre più spesso uso il MBP aperto anche quando collego il monitor esterno.

    Tornerò ad esaminare il problema facendo qualche prova.
    A presto
    MA

  3. Provate ad installare l’aggiornamento 10.6.2.
    Nella release note dice:
    Graphics fixes provided for:

    an issue when connecting monitors to DVI and Mini DisplayPort adapters

  4. Ale V. says

    Ciao Riccardo. A me parecchi mesi fa è successo un fatto ancor più strano… Appena acquistato il MBP(modello 15″, prima versione con slot express card) ho effettuato delle prove con l’adattatore miniDVD-DVI utilizzandolo per collegare un Apple Cinema Display 20″.
    Scollegando il monitor esterno a caldo la prima volta, il monitor sul MBP ha cominciato a “sfarfallare” falsando completamente i colori e la risoluzione. Nessun tipo di reset ha risolto il problema. Ho dovuto rimontare la Ram originale e successivamente reinstallare le 2 schede da 2 gb che avevo comprato. Da li onestamente (si parla di febbraio 2009) non ho più osato scollegare un monitor esterno con il MBP accedo. Collegandolo invece a caldo non ho mai riscontrato problemi. Comunque in rete non avevo trovato informazioni utili. Ciao

  5. Marco says

    Nel mio messaggio precedente, nel segnalare un problema passato (o comunque un problema che non mi si presenta da un po’) ho dimenticato di citarne uno attuale.

    Non sono bravo ad individuare il meccanismo sistematico che causa l’inconveniente, quindi anche in questo caso posso solo dire che il fatto si manifesta talvolta nel passare dalla modalità due schermi a quella solo monitor esterno (o forse da quella monitor integrato a quello esterno, devo farci caso).

    Il problema è questo: Exposè non funziona bene. Dal mio primo utilizzo di Exposè (quasi 3 anni fa) mi sono abituato ad usare l’angolo in basso a destra del monitor per accedere allo sfondo della scrivania. Talvolta mi capita appunto che spostando il puntatore non accade niente, e la cosa diventa molto seccante visto che è per me oramai un gesto automatico e continuo a farlo in continazione pur sapendo che non funziona. In questi casi decido dunque di riavviare il MBP per risolvere il problema.

    ps. Ecco! sta succedendo proprio mentre scrivo questo messaggio. Noto comunque che è tutto Exposè che funziona male, anche nel tentativo di avviaro da tastiera.

    Riavvio!

  6. Mi è tornato alla mente questo tuo intervento e i miei commenti di qualche mese fa!
    Adesso ovviamente ho aggiornato a Mac OS X 10.6.2. Il problema sembra ritornato! Adesso non posso collegare direttamente il fatto all’aggiornamento, perchè — ripeto — il fatto si presenta senza alcun criterio di tanto in tanto.

    Ricapitolo. Il problema di Exposè non mi capita più: passando dal monitor esterno a quello integrato (oppure dalla configurazione doppia a quella singolo monitor) Exposè funziona sempre (ultimamente) regolarmente.

    Torna invece a verificarsi il problema di qualche tempo fa: ovvero, talvolta risvegliando il MacBook Pro (unibody 15) dallo stop con il monitor principale chiuso e quello esterno connesso, il computer si blocca! Non si spegne, ma si blocca con il colore dello schermo azzurro e non posso fare altro che aprire il macbook e forzare lo spegnimento tenendo premuto il tasto power.

    A dire il vero non capita spessissimo, ma il solo fatto che talvolta succeda mi fa vivere ogni ripristino dallo stop con uno stato apprensione mista a fastidio. Tornare alla postazione di lavoro, battere sulla tastiera e attendere il responso del fato per capire se si tratta di ‘una di quelle volte’ è veramente frustrante.

    Per la cronaca, non mi ricordo se l’ho già specificato in precedenza, ho un Syncmaster T240HD della Samsung. Lo connetto mediante un adattatore MDisplayPort — DVI acquistato sullo store Apple.

Comments are closed.